Just read through 1 of the KB here which referring to the potential risk to create a purple screen scenerio during the vSphere 5 upgrade while you ESX host update 2 could potential conflict with the vCenter 5.

You may encounter an issue where:

  • You have recently upgraded your vCenter Server to version 5.0
  • You have hosts of minimum version ESXi 4.0 Update 2 (build 261974) and maximum version ESXi 4.0 Patch 9 (build 360236) in your vCenter Server inventory
  • After the vpxa agents are upgraded, the ESXi 4.0 Update 2 hosts experience a purple screen that includes this error:NOT_IMPLEMENTED bora/vmkernel/filesystems/visorfs/visorfsObj.c:3391
Solution
This issue has been resolved in ESXi 4.0 Update 3. To avoid this issue, upgrade all affected hosts to at least ESXi 4.0 Update 3 (build 398348) before upgrading vCenter Server to 5.0.
please refer to the full post here for more details.