For the past 1 week, I have been busy with the APC PCNS and ESXi 4.1 and I would like to share my experience “How to make APC PCNS 2.2.4 work with ESXi 4.1″ here.

Basically I will not discuss How To Install PowerChute Network Shutdown on VMware ESX /ESXi again and you may refer to APC official link here.

If you’re try to install APC PCNS 2.2.4 on vSphere Management Assistant (vMA) 4.1 and I’m sure you will get the similar error like “This version of PowerChute Network Shutdown only support VMware ESXi” which I think APC teams should it much more clear. The error message caused by APC PCNS (ver 2.2.4) setup file – “install.sh” which check on “/etc/vima-release” file. In the vMA 4.1 released, you’re can only found “/etc/vma-release” file which changed recently. Create a symbolic link or edit the installation script can temporary ignore these error message. See this link.
Read more »