If you are trying to install the Xencenter on Windows 7, you may face an error which due to the pre-requirement for .net framework 2.0 as part of the installation. It will fail automatically as windows 7 doesn’t support with .net framework 2.0 anymore. As there are number of solution posted on the internet, but is not easy to resolve this issue. Most easiest way is to get an XP machines install with the xencenter and manage the Xenserver and VMs from there. It just weird that the support on windows 7 is not available up to date, Citrix need to react faster as Windows 7 adoption is big wave going on to many enterprise and newly purchase desktop and laptop.